talkgroup

Rambling on Haiku OS

Tags: #<Tag:0x00007fd92106b0d8> #<Tag:0x00007fd92106af98> #<Tag:0x00007fd92106ae58>

Spent the afternoon with Haiku OS on real hardware the other day. I generally check it out once every year or two via virtual machine. It’s not secret BeOS was my start in the alternate OS rabbit hole and it really informed a lot of my computing preferences and ideas early on. Be Inc’s collapse really has a lot to do with why I stay with FLOSS platforms today.

While booting it up in Virtual Box I saw that had ported the entire Qt Creator suite which surprised me. I’ve been learning Qt; and Haiku’s Qt implementation is essentially native and so I decided to see if I could dial up a small demo app real quick. I kept having issues with the virtual NIC and virtual display though; and quickly noticed my actual GPU and WLAN device were supported… so real hardware it was.

All in all it was surprisingly useable. Like Haiku seems to be getting to a point where I could see myself using it again. Though probably not as my primary machine.

  • I expected Haiku to have a Caligra Office port but the LibreOffice port surprised me. Back when I used BeOS, several attempts at Open Office ports peculated and were all doomed to failure. A lot had to depend on it’s over reliance of Java even in it’s build system; and that was a time before Open JDK.
  • When I left BeOS for good, I actually wrote down the criteria for my return. Back then it was: A maintaned office suite with modern file formats, a java port, a modern browser with javascript. Haiku mostly hits these.
    • Little did I know Java would be of vastly less importance to me later.
  • At first glance Otter Browser seems like the best browser the platform has. It’s actually pretty capible. I cam across very few sites it couldn’t load. Though the more complex ones had performance issues. It’s extension system also remains unuseable to me. BeOS once had a functional Mozilla and Firefox port, but pre Haiku they were stuck on an old libc and old gcc version. So that port bitrotted. Modern Firefox requires a lot more middleware these days including rust support.
    • The BeOS native webkit based WebPositive browser the OS ships with is cute, but falls apart pretty quick under stress.
  • Haiku remains a single user affair like it’s predecessor. BeOS was always odd like that. Even back then it’s filesystem is posix style permissions and has owner/group attributes.
    • BeFS was also way ahead of it’s time; but lacks a lot of things in some areas we consider standard. Encryption being a big one.
  • A lot of Haiku and BeOS’s most interesting features kind of go unused if you mostly stick to ported apps; and native apps seem increasingly far and few between. Like the TranslationKit API was basically gstreamer for documents. Which is freaking brilliant. But if your using libreoffice / caligra office / otter browser for most of your document needs. What is the point?
    • This kind of highlights a big need for atleast a small number of “killer” apps. Though it seems to me that all of BeOS’s killer apss from back in the day are pretty dead now. SoundPlay by far was such a big deal; id still like to have it now, GoBe Productive, etc, etc. All of BeOS’s must have apps were proprietary; and are therefore now dead.
  • Didn’t see anything capible of caldav calendaring.
  • No syncthing port or nextcloud client.
  • No Frotz or Gargoyle in the repositories.
  • RetroArch with all the cores is available.
  • Psi+ with OMEMO support was a pleasant surprise.
    • I lived in NetBSD for a long while struggling to find any good OMEMO support that would compile for me.
  • Port of the official Telegram client surprised.
  • BeOS native and specific file sharing app BeShare and it’s associated file sharing network is still up and has files.
    • Worms Armageddon port I downloaded off BeShare doesn’t get very far before crashing due to unknown reasons. Which is a shame. I used to play that a bit back in the day. The port was pre-release quality I believe. One of those things where they paid a porter to port it, but the project got scuttled towards the end.
      • Couldn’t find the Civ CTP II port. It’s a really good port. I owned that at one point. Think I gave it away during my last move.
  • Had to disable Advance Power Management in the installer’s boot menu to get it to install, but the OS was fine with power management after installation.
  • It HATED my system clock. Kept interpretting the system clock as being 20+ years in the future. Even when it was set to record time back to the system in GMT unix style. I ended up just having it and KDE Neon sync from network servers and let them battle it out at the beginning of each boot.
    • This might be a Coreboot thing. Though ive not noticed such a problem on any other OS on my machine so far.
  • The whole thing felt solid and responsive and fun. It felt very much like BeOS. It really made me think the project can still carve out it’s own usefull nitch.
1 Like

How does talkgroup load?

Wow! I didn’t even know Psi+ had OMEMO support. :grimacing:

It’s almost like the OS is stuck thinking about a bygone era. But what was happening ~20 years ago?! :slight_smile:

1 Like

Talkgroup ran fine in Otter Browser. As did Mastodon. Youtube gave it some pause but was browseable. CNN crashed it once but was otherwise able to view it on repeat tries. Nextcloud ran about perfect. OnlyOffice integrated with Nextcloud was sluggish bute useable.

I had another former BeOS refuge I was chatting with me, send me some direct links to some high complex google speadsheets. And it loaded those with EXTREME difficulty.

It’s in an external plugin you have to enable. Most distros ive tried don’t carry the plugin. Psi isn’t my goto honestly. Its UI is a little busy for my tastes, but OMEMO support is still kinda rare take what you can get sometimes.

I only remembered to check Psi because I recalled it from https://omemo.top

HAA!!

You know if I didn’t know that this was a clean room rewrite. I swear I had similar system clock bugs jumping between OSes and BeOS back in the 90s…

1 Like

Got yammering to one of the more active Haiku developers in the fediverse today. Ended up picking up an ancient but cheap Lenovo Ideapad S10-3 off of ebay, as a kind of semi permenant Haiku toy machine.

Would have tried to see if the GPD Pocket 2 could have been used for this for the time being; but Haiku doesn’t seem to support screen rotation just yet; and thats mandatory, as GPD hardware use mobile LCDs turned sideways.

Would have waited for the recently anounced ARM port, on Pine64 hardware. But the Haiku developer convinced me its a good long ways off from being useable.

1 Like

The workaround is to tilt your head. :grin:

1 Like

Haiku Developer corrected me today on this point. Theyve actually done all the work to make the whole system multiuser aware. They just haven’t setup graphical user session management yet. So the system boots into the default user. So it definitely sounds like it is coming in the not to distant future.

1 Like

The S10-3 typically ships with one of two wifi cards. Both of which have Haiku drivers.

Something is up with the AR9285 chipset and it’s driver though. If enabled, it causes Haiku to drop the user into kernel debugger land. Haiku imports wifi drivers from FreeBSD; and I couldn’t find any exact bugs corresponding to this in FreeBSD. There are though lots of bugs talking about general AR285 instability.

Archwiki has a weird note:

Some users report issues with the ath9k driver and this particular chipset. In this case, use the ndiswrapper method.

Im just going to pickup this netbook’s alternate OEM WiFi card off of ebay. Which is in the BCM4113. Hopefully that will work out better.