talkgroup

Upgrading: Fedora 29 to 30

Upgrading to Fedora 30. Kinda following along at Upgrading Fedora 29 to Fedora 30 - Fedora Magazine.

As I already have dnf-plugin-system-upgrade installed, it is a matter of:

sudo dnf system-upgrade download --releasever=30

I’m timing it, so we’ll see how long it takes. :slight_smile:

Transaction Summary
=========================================================
Install    48 Packages
Upgrade  2290 Packages
Remove      6 Packages
Download complete! Use 'dnf system-upgrade reboot' to start the upgrade.
To remove cached metadata and transaction use 'dnf system-upgrade clean'
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.

real	280m38.752s
user	17m9.765s
sys	3m36.062s

Waited a few minutes but the progress bar hasn’t budged at all…

Planning on walking away and seeing if it “just works”! :sunglasses:

1 Like

Hey! It does!

And the lines and colors are ever sharp as I return to ignoring my OS…

Ah, I spoke too soon, and have been debugging this for a while. I found bunches of posts, but should have started at Common F30 bugs - Fedora Project Wiki.

:link: Broadcom wireless adapters using proprietary broadcom-wl driver do not work reliably

link to this item - Bugzilla: #1703745

Multiple users of wireless network adapters supported by the proprietary broadcom-wl driver have reported that it does not work reliably in Fedora 30. PLEASE NOTE that Fedora does not provide or support this proprietary driver; we are providing this note only as a courtesy as we are aware that many people acquire the driver from a third party and use it on Fedora.

The problem seems to be that a new feature in wpa_supplicant that was enabled in Fedora 30 confuses the broadcom-wl driver. As the driver is not open source we cannot provide a fixed version of it, and we will not disable a useful wpa-supplicant feature just to make a proprietary driver work correctly.

To help out folks with affected devices, Davide Caratti is providing unofficial rebuilds of wpa_supplicant with the feature in question disabled. You can enable his COPR repository by running sudo dnf copr enable dcaratti/wpa_supplicant , and then updating your system should install his rebuild, if it is currently up-to-date compared to the version in the official repositories. With this rebuild installed, the wireless adapter should work reliably.

Adding that repo now, let’s :crossed_fingers:t4:!

And it worked! Back on wifi.

Never buy Broadcom.